Komodo 6 version error :(

Уже на протяжении нескольких недель Komodo парит мне мозги вот такова рода ошибками. Если честно уже надоело и в порыве злобы на него я полез искать другую альтернативу редактора, но решил осмотреть еще раз не понятный мне лог ошибки повнимательней

Error list (small)

Process:         komodo-bin [1501]
Path:            /Applications/Komodo Edit.app/Contents/MacOS/komodo-bin
Identifier:      com.activestate.Komodo
Version:         6.0 (6.0)
Code Type:       X86 (Native)
Parent Process:  launchd [208]
cut
8   org.activestate.ActivePython26	0x1290519f PyEval_CallObjectWithKeywords + 72 (ceval.c:3619)
9   org.activestate.ActivePython26	0x128750c7 instance_getattr + 449 (classobject.c:763)
10  org.activestate.ActivePython26	0x12900bf4 builtin_getattr + 115 (bltinmodule.c:828)
cut
0x13508000 - 0x1350bffb +_struct.so ??? (???) /Applications/Komodo Edit.app/Contents/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload/_struct.so
0x1351c000 - 0x1352107f +binascii.so ??? (???) /Applications/Komodo Edit.app/Contents/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload/binascii.so
0x1352b000 - 0x1352bffc +_scproxy.so ??? (???) /Applications/Komodo Edit.app/Contents/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload/_scproxy.so
0x13572000 - 0x13573fff +_hashlib.so ??? (???) /Applications/Komodo Edit.app/Contents/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload/_hashlib.so
cut

Питоновский интерпритатор в то время говорит

----------------------------------------
Exception happened during processing of request from ('127.0.0.1', 56000)
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 284, in _handle_request_noblock
    self.process_request(request, client_address)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 310, in process_request
    self.finish_request(request, client_address)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 323, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/django/core/servers/basehttp.py", line 562, in __init__
    BaseHTTPRequestHandler.__init__(self, *args, **kwargs)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 641, in __init__
    self.finish()
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 694, in finish
    self.wfile.flush()
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 301, in flush
    self._sock.sendall(view[write_offset:write_offset+buffer_size])
error: [Errno 32] Broken pipe
----------------------------------------

Вот я и подумал может комодо не тот питоновский интерпритатор юзает. Он указывал на /usr/bin/python, вот тут то и косяк=), здесь у меня 2.6.1 а тут /usr/local/bin/python 2.6.4 =) весело. Насильно его навел на мне нужный /Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7. Очень надеюсь, что на этом шалости закончатся.

Рубрики: Development
Метки: , , ,

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *